Sets the properties for the ellipse
entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void Set(
Point3d center,
Vector3d unitNormal,
Vector3d majorAxis,
double radiusRatio,
double startAngle,
double endAngle
)
Public Sub Set (
center As Point3d,
unitNormal As Vector3d,
majorAxis As Vector3d,
radiusRatio As Double,
startAngle As Double,
endAngle As Double
)
public:
void Set(
Point3d center,
Vector3d unitNormal,
Vector3d majorAxis,
double radiusRatio,
double startAngle,
double endAngle
)
member Set :
center : Point3d *
unitNormal : Vector3d *
majorAxis : Vector3d *
radiusRatio : float *
startAngle : float *
endAngle : float -> unit
Parameters
- center Point3d
- [in] WCS center of this ellipse.
- unitNormal Vector3d
- [in] WCS unit normal to the plane on which this ellipse
lies.
- majorAxis Vector3d
- [in] Major axis of this ellipse.
- radiusRatio Double
- [in] Ratio of minor radius to major radius. To construct a
valid object, this parameter must not be less than 1E-6 or greater
than 1.0.
- startAngle Double
- [in] Start angle.
- endAngle Double
- [in] End angle.
Remarks
All angles are
expressed in radians. A closed ellipse entity must have (StartAngle
= 0) and (EndAngle = Oda2PI) and (EndAngle - StartAngle) > 1e-6.
The radius ratio must be in the range [1e-6 to 1.0]. The major axis
must be perpendicular to the normal within 1e-6.
See Also