PlotStyleDescriptor Structure

This class encapsulates a PlotStyleNameType enum value and the object ID of the associated plot style name dictionary entry.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesPlotStyleDescriptor

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct PlotStyleDescriptor

The PlotStyleDescriptor type exposes the following members.

Constructors
  Name Description
Public method PlotStyleDescriptor Constructor for the PlotStyleDescriptor structure.
Top
Properties
  Name Description
Public property Id  
Public property Type  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method ToString
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(PlotStyleDescriptor, PlotStyleDescriptor) Equality operator for the PlotStyleDescriptor class. Checks whether plot style descriptors are equal.
Public operatorStatic member Inequality(PlotStyleDescriptor, PlotStyleDescriptor) Equality operator for the PlotStyleDescriptor class. Checks whether plot style descriptors are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.