ImageFileTexture Class

This class defines material textures based on image files.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceMaterialTexture
          Teigha.GraphicsInterfaceImageTexture
            Teigha.GraphicsInterfaceImageFileTexture

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class ImageFileTexture : ImageTexture, 
        ICloneable

The ImageFileTexture type exposes the following members.

Constructors
  Name Description
Public method ImageFileTexture Default constructor for the ImageFileTexture class.
Top
Properties
  Name Description
Public property SourceFileName  
Top
Methods
  Name Description
Public method Clone Returns the cloned image file texture.
(Overrides RXObjectClone)
Public method Equals
(Overrides DisposableWrapperEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides DisposableWrapperGetHashCode)
Top
Operators
  Name Description
Public operatorStatic member Equality(ImageFileTexture, ImageFileTexture) Equality operator for the ImageFileTexture class. Checks whether image file textures are equal.
Public operatorStatic member Inequality(ImageFileTexture, ImageFileTexture) Inequality operator for the ImageFileTexture class. Checks whether image file textures are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.