RXObject Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        More

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class RXObject : DisposableWrapper, 
        ICloneable

The RXObject type exposes the following members.

Constructors
  Name Description
Protected method RXObject Initializes a new instance of the RXObject class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method Clone  
Public method CompareTo  
Public method CopyFrom  
Public methodStatic member Create  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public methodStatic member GetClass  
Public method GetRXClass  
Public method QueryX  
Public method X  
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Bricscad.CivilCivilSubObjectBase
        Teigha.Aec.DatabaseServicesImpObject
        Teigha.DatabaseServicesAbstractViewPE
        Teigha.DatabaseServicesAssocArrayParameters
        Teigha.DatabaseServicesCompoundObjectId
        Teigha.DatabaseServicesConstraintGroupNode
        Teigha.DatabaseServicesDatabase
        Teigha.DatabaseServicesDataCell
        Teigha.DatabaseServicesDataColumn
        Teigha.DatabaseServicesDataLinkManager
        Teigha.DatabaseServicesDbDictionaryEnumerator
        Teigha.DatabaseServicesDwgFiler
        Teigha.DatabaseServicesDxfFiler
        Teigha.DatabaseServicesFieldEngine
        Teigha.DatabaseServicesFieldEvaluator
        Teigha.DatabaseServicesFieldEvaluatorLoader
        Teigha.DatabaseServicesFieldResult
        Teigha.DatabaseServicesGeomRef
        Teigha.DatabaseServicesHostApplicationServices
        Teigha.DatabaseServicesIdMapping
        Teigha.DatabaseServicesLayerStateManager
        Teigha.DatabaseServicesLayoutManager
        Teigha.DatabaseServicesLayoutPaperPE
        Teigha.DatabaseServicesMatchProperties
        Teigha.DatabaseServicesObjectContext
        Teigha.DatabaseServicesObjectContextCollection
        Teigha.DatabaseServicesObjectContextCollectionEnumerator
        Teigha.DatabaseServicesObjectContextManager
        Teigha.DatabaseServicesObjectIterator
        Teigha.DatabaseServicesPlotStyle
        Teigha.DatabaseServicesPlotStyleTable
        Teigha.DatabaseServicesPointRef
        Teigha.DatabaseServicesTransaction
        Teigha.DatabaseServicesTransactionManager
        Teigha.DatabaseServicesUnderlayHost
        Teigha.Export_ImportDWFImport
        Teigha.GraphicsInterfaceCommonDraw
        Teigha.GraphicsInterfaceContext
        Teigha.GraphicsInterfaceDisplayStyle
        Teigha.GraphicsInterfaceDrawable
        Teigha.GraphicsInterfaceDrawableTraits
        Teigha.GraphicsInterfaceEdgeStyle
        Teigha.GraphicsInterfaceFaceStyle
        Teigha.GraphicsInterfaceGeometry
        Teigha.GraphicsInterfaceGIRasterImage
        Teigha.GraphicsInterfaceLightAttenuation
        Teigha.GraphicsInterfaceMapper
        Teigha.GraphicsInterfaceMaterialColor
        Teigha.GraphicsInterfaceMaterialMap
        Teigha.GraphicsInterfaceMaterialTexture
        Teigha.GraphicsInterfaceShadowParameters
        Teigha.GraphicsInterfaceTextStyle
        Teigha.GraphicsInterfaceVariant
        Teigha.GraphicsInterfaceViewport
        Teigha.GraphicsInterfaceVisualStyle
        Teigha.GraphicsSystemDevice
        Teigha.GraphicsSystemModel
        Teigha.GraphicsSystemView
        Teigha.LayerManagerLayerFilter
        Teigha.RuntimeDictionary
        Teigha.RuntimeDictionaryIterator
        Teigha.RuntimeDynamicLinker
        Teigha.RuntimeModule
        Teigha.RuntimeOverrule
        Teigha.RuntimeRXClass
        Teigha.RuntimeRxVariant
        Teigha.RuntimeStreamBuf

©  Bricsys NV. All rights reserved.