ViewportGeometryDeviceContextRasterImage
Method
|
Draws the specified raster image.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool DeviceContextRasterImage(
Point3d origin,
Vector3d u,
Vector3d v,
Matrix2d pixel,
ObjectId entityId,
ImageOrg imageOrg,
int imageWidth,
int imageHeight,
short imageColorDepth,
bool transparency,
ImageSource source,
Vector3d unRotated,
ImageOrg originalImage,
Matrix2d unRotatedPixel,
int unRotatedImageWidth,
int unRotatedImageHeight
)
Public MustOverride Function DeviceContextRasterImage (
origin As Point3d,
u As Vector3d,
v As Vector3d,
pixel As Matrix2d,
entityId As ObjectId,
imageOrg As ImageOrg,
imageWidth As Integer,
imageHeight As Integer,
imageColorDepth As Short,
transparency As Boolean,
source As ImageSource,
unRotated As Vector3d,
originalImage As ImageOrg,
unRotatedPixel As Matrix2d,
unRotatedImageWidth As Integer,
unRotatedImageHeight As Integer
) As Boolean
public:
virtual bool DeviceContextRasterImage(
Point3d origin,
Vector3d u,
Vector3d v,
Matrix2d pixel,
ObjectId entityId,
ImageOrg imageOrg,
int imageWidth,
int imageHeight,
short imageColorDepth,
bool transparency,
ImageSource source,
Vector3d unRotated,
ImageOrg originalImage,
Matrix2d unRotatedPixel,
int unRotatedImageWidth,
int unRotatedImageHeight
) abstract
abstract DeviceContextRasterImage :
origin : Point3d *
u : Vector3d *
v : Vector3d *
pixel : Matrix2d *
entityId : ObjectId *
imageOrg : ImageOrg *
imageWidth : int *
imageHeight : int *
imageColorDepth : int16 *
transparency : bool *
source : ImageSource *
unRotated : Vector3d *
originalImage : ImageOrg *
unRotatedPixel : Matrix2d *
unRotatedImageWidth : int *
unRotatedImageHeight : int -> bool
Parameters
- origin Point3d
- [in] Image origin.
- u Vector3d
- [in] Image width vector.
- v Vector3d
- [in] Image height vector.
- pixel Matrix2d
- [in] Image pixel coordinate to display the coordinate
transformation matrix.
- entityId ObjectId
- [in] Persistent object identifier of the image.
- imageOrg ImageOrg
- [in] Image format organization.
- imageWidth Int32
- [in] Image width in pixels.
- imageHeight Int32
- [in] Image height in pixels.
- imageColorDepth Int16
- [in] Image color depth (bits per pixel).
- transparency Boolean
- [in] Flag that indicates whether the image has transparent
parts.
- source ImageSource
- [in] Image source.
- unRotated Vector3d
- [in] Non-rotated image origin.
- originalImage ImageOrg
- [in] Original image format organization.
- unRotatedPixel Matrix2d
- [in] Unrotated pixel-to-DC transformation matrix.
- unRotatedImageWidth Int32
- [in] Unrotated source image width defined in pixels.
- unRotatedImageHeight Int32
- [in] Unrotated source image height defined in pixels.
Return Value
Boolean
true. This method also throws a
corresponding exception if it fails.
See Also