ConeSet(Double, Double, Point3d, Double,
Vector3d, Vector3d, Interval, Double, Double)
Method
|
Sets the parameters for this cone according to
the arguments.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void Set(
double cosineAngle,
double sineAngle,
Point3d baseCenter,
double baseRadius,
Vector3d axisOfSymmetry,
Vector3d refAxis,
Interval height,
double startAngle,
double endAngle
)
Public Sub Set (
cosineAngle As Double,
sineAngle As Double,
baseCenter As Point3d,
baseRadius As Double,
axisOfSymmetry As Vector3d,
refAxis As Vector3d,
height As Interval,
startAngle As Double,
endAngle As Double
)
public:
void Set(
double cosineAngle,
double sineAngle,
Point3d baseCenter,
double baseRadius,
Vector3d axisOfSymmetry,
Vector3d refAxis,
Interval^ height,
double startAngle,
double endAngle
)
member Set :
cosineAngle : float *
sineAngle : float *
baseCenter : Point3d *
baseRadius : float *
axisOfSymmetry : Vector3d *
refAxis : Vector3d *
height : Interval *
startAngle : float *
endAngle : float -> unit
Parameters
- cosineAngle Double
- [in] The cosine of the angle between the generating line and
the axis of symmetry.
- sineAngle Double
- [in] The sine of the angle between the generating line and the
axis of symmetry.
- baseCenter Point3d
- [in] Center of the base.
- baseRadius Double
- [in] Radius of the base.
- axisOfSymmetry Vector3d
- [in] Axis of symmetry (rotation).
- refAxis Vector3d
- [in] Defines angle 0 of the circular base.
- height Interval
- [in] Height interval of this cone.
- startAngle Double
- [in] Axis of symmetry (rotation).
- endAngle Double
- [in] Axis of symmetry (rotation).
See Also