TextStyleExtentsBox
Method
|
Calculates the extents of the specified text
string when using this text style. Currently not implemented.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Extents2d ExtentsBox(
string text,
bool includeSpaces,
bool raw,
WorldDraw worldDraw
)
Public Function ExtentsBox (
text As String,
includeSpaces As Boolean,
raw As Boolean,
worldDraw As WorldDraw
) As Extents2d
public:
Extents2d ExtentsBox(
String^ text,
bool includeSpaces,
bool raw,
WorldDraw^ worldDraw
)
member ExtentsBox :
text : string *
includeSpaces : bool *
raw : bool *
worldDraw : WorldDraw -> Extents2d
Parameters
- text String
- [in] Text string for which to calculate extents.
- includeSpaces Boolean
- [in] If true, includes leading and trailing spaces in the
calculation process.
- raw Boolean
- [in] If true, escape sequences, such as %%P, are not converted
to special characters.
- worldDraw WorldDraw
- [in] WorldDraw interface. If NULL, the default regen pipeline
is used.
Return Value
Extents2d
See Also