Extents2d Structure

This class represents 2D bounding boxes as minimum and maximum 2D points for various graphical objects.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesExtents2d

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Extents2d : IFormattable

The Extents2d type exposes the following members.

Constructors
  Name Description
Public method Extents2d(Point2d, Point2d) Constructor for the Extents2d class. Creates extents from the specified points.
Public method Extents2d(Double, Double, Double, Double) Constructor for the Extents2d class. Creates extents from the specified values for minimum and maximum points.
Top
Properties
  Name Description
Public property MaxPoint Property that represents the maximum point of this extents.
Public property MinPoint Property that represents the minimum point of this extents.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method IsEqualTo(Extents2d) Compares this object to another object.
Public method IsEqualTo(Extents2d, Tolerance) Compares this object to another object within the specified tolerance.
Public method ToString
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Public method ToString(String, IFormatProvider) Returns an equivalent string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(Extents2d, Extents2d) Equality operator for the Extents2d class. Checks whether the passed objects are equal.
Public operatorStatic member Inequality(Extents2d, Extents2d) Inequality operator for the Extents2d class. Checks whether the passed objects are equal.
Top
See Also

©  Bricsys NV. All rights reserved.