Cuts a face in two using two points on
different edges of the original face.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SplitFace(
SubentityId subentFaceId,
SubentityId subent0,
Point3d point0,
SubentityId subent1,
Point3d point1
)
Public Sub SplitFace (
subentFaceId As SubentityId,
subent0 As SubentityId,
point0 As Point3d,
subent1 As SubentityId,
point1 As Point3d
)
public:
void SplitFace(
SubentityId subentFaceId,
SubentityId subent0,
Point3d point0,
SubentityId subent1,
Point3d point1
)
member SplitFace :
subentFaceId : SubentityId *
subent0 : SubentityId *
point0 : Point3d *
subent1 : SubentityId *
point1 : Point3d -> unit
Parameters
- subentFaceId SubentityId
- [in] Subentity ID of the face to cut.
- subent0 SubentityId
- [in] Subentity ID of the first edge.
- point0 Point3d
- [in] Point on the first edge.
- subent1 SubentityId
- [in] Subentity ID of the second edge.
- point1 Point3d
- [in] Point on the second edge.
See Also