GeometryImage(ImageBGRA32,
Point3d, Vector3d, Vector3d,
TransparencyMode) Method
|
Introduces an image in BGRA format into the
vectorization context.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool Image(
ImageBGRA32 imageSource,
Point3d position,
Vector3d u,
Vector3d v,
TransparencyMode transparencyMode
)
Public MustOverride Function Image (
imageSource As ImageBGRA32,
position As Point3d,
u As Vector3d,
v As Vector3d,
transparencyMode As TransparencyMode
) As Boolean
public:
virtual bool Image(
ImageBGRA32^ imageSource,
Point3d position,
Vector3d u,
Vector3d v,
TransparencyMode transparencyMode
) abstract
abstract Image :
imageSource : ImageBGRA32 *
position : Point3d *
u : Vector3d *
v : Vector3d *
transparencyMode : TransparencyMode -> bool
Parameters
- imageSource ImageBGRA32
- [in] Image in BGRA format.
- position Point3d
- [in] Image position in WCS.
- u Vector3d
- [in] Image width and x-axis orientation.
- v Vector3d
- [in] Image height and y-axis orientation.
- transparencyMode TransparencyMode
- [in] Image transparency processing mode.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
See Also