ViewSetView(Point3d, Point3d, Vector3d, Double, Double, Projection) Method

Sets the camera parameters for this Viewport object.

Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void SetView(
        Point3d position,
        Point3d target,
        Vector3d upVector,
        double fieldWidth,
        double fieldHeight,
        Projection projection
)

Parameters

position  Point3d
[in] Camera position.
target  Point3d
[in] Camera target.
upVector  Vector3d
[in] Camera up vector.
fieldWidth  Double
[in] Projection plane (field) width.
fieldHeight  Double
[in] Projection plane (field) height.
projection  Projection
[in] Projection type.
Remarks
This method defines the transformation from WCS coordinates to normalized device coordinates. All parameters are in WCS coordinates. projection must be one of the following: NameValueParallel 0 Perspective 1
See Also

©  Bricsys NV. All rights reserved.