NurbSurfaceEvaluate(Double,
Double) Method
|
Evaluates the position on the NURBS surface at
the specified parameter value (u, v) and returns the evaluated
point.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d Evaluate(
double dU,
double dV
)
Public Function Evaluate (
dU As Double,
dV As Double
) As Point3d
public:
Point3d Evaluate(
double dU,
double dV
)
member Evaluate :
dU : float *
dV : float -> Point3d
Parameters
- dU Double
- [in] U-direction parameter.
- dV Double
- [in] V-direction parameter.
Return Value
Point3d
Remarks
If the surface
doesn't contain any NURBS information, throws the eFail exception. If the dU
or dV value is out of range, throws the
eOutOfRange exception. If this method is
not implemented for a specific modeler, throws the eNotImplementedYet exception.
See Also