QuadItemRegistry Class

This helper class is provied to collect all the QuadItems, the client implementation intends to use; all QuadItems must be declared upfront, prior to its usage. QuadItems can be declared using this class, during 'AcEdQuadReactor::registerQuadItems()' callback.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.QuadQuadItemRegistry

Namespace: Bricscad.Quad
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class QuadItemRegistry : DisposableWrapper

The QuadItemRegistry type exposes the following members.

Properties
  Name Description
Top
Methods
  Name Description
Public method append use this function from inside your implementation of 'AcEdQuadReactor::registerQuadItems()', to register all your QuadItems; 'szQuadItemId' should be unique within the scope of the reactor; 'szLabel', 'szIcon' and 'szCommand' should not be NULL or empty; 'szTooltip' can be NULL or empty; returns true if registration was successful
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Top
See Also

©  Bricsys NV. All rights reserved.