EntityExplodeGeometryToBlock(BlockTableRecord,
ObjectIdCollection) Method
|
Explodes this entity into a set of simpler
entities and adds them to the specified block.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void ExplodeGeometryToBlock(
BlockTableRecord btr,
ObjectIdCollection objIdCollection
)
Public Overridable Sub ExplodeGeometryToBlock (
btr As BlockTableRecord,
objIdCollection As ObjectIdCollection
)
public:
virtual void ExplodeGeometryToBlock(
BlockTableRecord^ btr,
ObjectIdCollection^ objIdCollection
)
abstract ExplodeGeometryToBlock :
btr : BlockTableRecord *
objIdCollection : ObjectIdCollection -> unit
override ExplodeGeometryToBlock :
btr : BlockTableRecord *
objIdCollection : ObjectIdCollection -> unit
Parameters
- btr BlockTableRecord
- [in] BlockTableRecord for which to append a set of entities
resulting from the explosion.
- objIdCollection ObjectIdCollection
- [in/out] Receives a collection of new entities. May contain
elements before method execution; new elements are appended to the
end of the collection.
Remarks
The newly created
entities are database-resident or not, depending on the owner block
table record. If the block table record is database-resident, the
entities are database-resident too. If the block table record is
not database-resident, newly created entities are not
database-resident. Entities resulting from the explosion are
appended to the specified collection. The default implementation of
this function calls subWorldDraw() and makes entities from geometry
generated by subWorldDraw(). This method can be overridden in
custom classes.
See Also