OffsetCurve3d Constructor

Constructor for the OffsetCurve3d class. Constructs a curve from the base curve that lies on a plane with a 'planeNormal' normal vector to that plane. The curve is offset by the specified distance.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public OffsetCurve3d(
        Curve3d baseCurve,
        Vector3d planeNormal,
        double offsetDistance
)

Parameters

baseCurve  Curve3d
[in] Base curve.
planeNormal  Vector3d
[in] A 3D vector to be set as the normal to the plane of the base curve.
offsetDistance  Double
[in] Offset distance.
See Also

©  Bricsys NV. All rights reserved.