OffsetCurve3d Class

This class represents 3D offset curves. For more information, see Working with Offset Curves.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometryCurve3d
          Teigha.GeometryOffsetCurve3d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class OffsetCurve3d : Curve3d

The OffsetCurve3d type exposes the following members.

Constructors
  Name Description
Public method OffsetCurve3d Constructor for the OffsetCurve3d class. Constructs a curve from the base curve that lies on a plane with a 'planeNormal' normal vector to that plane. The curve is offset by the specified distance.
Top
Properties
  Name Description
Public property Curve  
Public property Normal  
Public property OffsetDistance  
Public property ParameterDirection  
Public property Transformation  
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Top
See Also

©  Bricsys NV. All rights reserved.