TableGridVisibility(GridLineType,
RowType) Method
|
Returns the grid visibility for the specified
gridline type and row type in this table entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual bool GridVisibility(
GridLineType gridlineType,
RowType type
)
Public Overridable Function GridVisibility (
gridlineType As GridLineType,
type As RowType
) As Boolean
public:
virtual bool GridVisibility(
GridLineType gridlineType,
RowType type
)
abstract GridVisibility :
gridlineType : GridLineType *
type : RowType -> bool
override GridVisibility :
gridlineType : GridLineType *
type : RowType -> bool
Parameters
- gridlineType GridLineType
- [in] Gridline type.
- type RowType
- [in] Row type.
Return Value
Boolean
Grid visibility value that can be one of the following:
NameValueVisible 0 Invisible 1
Remarks
The gridlineType
parameter must have one of the following values:
NameValueDescriptionHorizontalTop 0x01 Top or
bottom horizontal table's grid line, depending on the flow
direction of the table rows (down or up). HorizontalInside 0x02 All
horizontal grid lines, excluding the bottom and top lines.
HorizontalBottom 0x04 Bottom or top horizontal table's grid line,
depending on the flow direction of the table rows (down or up).
VerticalLeft 0x08 The grid line at the left of the table.
VerticalInside 0x10 All vertical grid lines, excluding the left and
right lines. VerticalRight 0x20 The grid line at the right of the
table.
See Also