RadialDimensionLarge(Point3d,
Point3d, Point3d, Point3d, Double, String,
ObjectId) Constructor
|
Constructor. Creates a RadialDimensionLarge
object with specified parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public RadialDimensionLarge(
Point3d center,
Point3d chordPoint,
Point3d overrideCenter,
Point3d jogPoint,
double jogAngle,
string dimensionText,
ObjectId dimensionStyle
)
Public Sub New (
center As Point3d,
chordPoint As Point3d,
overrideCenter As Point3d,
jogPoint As Point3d,
jogAngle As Double,
dimensionText As String,
dimensionStyle As ObjectId
)
public:
RadialDimensionLarge(
Point3d center,
Point3d chordPoint,
Point3d overrideCenter,
Point3d jogPoint,
double jogAngle,
String^ dimensionText,
ObjectId dimensionStyle
)
new :
center : Point3d *
chordPoint : Point3d *
overrideCenter : Point3d *
jogPoint : Point3d *
jogAngle : float *
dimensionText : string *
dimensionStyle : ObjectId -> RadialDimensionLarge
Parameters
- center Point3d
- [in] Center point of the circle or arc to be measured.
- chordPoint Point3d
- [in] Chord point on the circle or arc to be measured, and to
which the dimension line is drawn.
- overrideCenter Point3d
- [in] Origin point from which the dimension line is drawn.
- jogPoint Point3d
- [in] Point at which the dimension line jogs when it passes from
the override point to the chord point.
- jogAngle Double
- [in] Jog angle between the line through the overridden center
point and line through the jog point.
- dimensionText String
- [in] Dimension text to replace the measured value text.
- dimensionStyle ObjectId
- [in] ObjectId of the dimension style that is used to draw the
dimension entity.
See Also