CircularArc2dGetTangent(Point2d, Tolerance)
Method
|
Retrieves the tangent line at the specified
point according to the specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Line2d GetTangent(
Point2d point,
Tolerance tolerance
)
Public Function GetTangent (
point As Point2d,
tolerance As Tolerance
) As Line2d
public:
Line2d^ GetTangent(
Point2d point,
Tolerance tolerance
)
member GetTangent :
point : Point2d *
tolerance : Tolerance -> Line2d
Parameters
- point Point2d
- [in] Point at which the tangent line is calculated.
- tolerance Tolerance
- [in] Geometry tolerance.
Return Value
Line2d
Tangent 2D line represented by the Line2d class.
See Also