CurveGetClosestPointTo(Point3d,
Boolean) Method
|
Returns the point on this curve closest to the
given point.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual Point3d GetClosestPointTo(
Point3d givenPoint,
bool extend
)
Public Overridable Function GetClosestPointTo (
givenPoint As Point3d,
extend As Boolean
) As Point3d
public:
virtual Point3d GetClosestPointTo(
Point3d givenPoint,
bool extend
)
abstract GetClosestPointTo :
givenPoint : Point3d *
extend : bool -> Point3d
override GetClosestPointTo :
givenPoint : Point3d *
extend : bool -> Point3d
Parameters
- givenPoint Point3d
- [in] Point for which to calculate the closest point on this
curve.
- extend Boolean
- [in] Extends this curve if and only if true.
Return Value
Point3d
See Also