NurbCurve3dSetFitData(Point3dCollection,
Vector3d, Vector3d,
KnotParameterizationEnum, Tolerance) Method
|
Sets the fit data for this spline.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetFitData(
Point3dCollection fitPoints,
Vector3d startTangent,
Vector3d endTangent,
KnotParameterizationEnum knotParam,
Tolerance fitTolerance
)
Public Sub SetFitData (
fitPoints As Point3dCollection,
startTangent As Vector3d,
endTangent As Vector3d,
knotParam As KnotParameterizationEnum,
fitTolerance As Tolerance
)
public:
void SetFitData(
Point3dCollection^ fitPoints,
Vector3d startTangent,
Vector3d endTangent,
KnotParameterizationEnum knotParam,
Tolerance fitTolerance
)
member SetFitData :
fitPoints : Point3dCollection *
startTangent : Vector3d *
endTangent : Vector3d *
knotParam : KnotParameterizationEnum *
fitTolerance : Tolerance -> unit
Parameters
- fitPoints Point3dCollection
- [in] Interpolation points.
- startTangent Vector3d
- [in] Start tangent.
- endTangent Vector3d
- [in] End tangent.
- knotParam KnotParameterizationEnum
-
- fitTolerance Tolerance
- [in] Geometric tolerance.
Remarks
Replaces any
existing spline data (fit or NURBS) with the fit data fitPoints,
startTangent, endTangent, knot parameterization, and fitTolerance.
fitPoints must contain two or more points. If fitTolerance is not
0, the constructed spline may not pass through the fit points, but
the maximum distance from any fit point to the constructed spline
is no greater than fitTolerance.
See Also