HatchAppendLoop(HatchLoopTypes,
Curve2dCollection, IntegerCollection)
Method
|
Appends a loop to this hatch entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void AppendLoop(
HatchLoopTypes loopType,
Curve2dCollection edgePtrCollection,
IntegerCollection edgeTypeCollection
)
Public Sub AppendLoop (
loopType As HatchLoopTypes,
edgePtrCollection As Curve2dCollection,
edgeTypeCollection As IntegerCollection
)
public:
void AppendLoop(
HatchLoopTypes loopType,
Curve2dCollection^ edgePtrCollection,
IntegerCollection^ edgeTypeCollection
)
member AppendLoop :
loopType : HatchLoopTypes *
edgePtrCollection : Curve2dCollection *
edgeTypeCollection : IntegerCollection -> unit
Parameters
- loopType HatchLoopTypes
- [in] Type of loop to append.
- edgePtrCollection Curve2dCollection
- [in] The edges that comprise this loop.
- edgeTypeCollection IntegerCollection
- [in] The edge types corresponding to the edges collection. Is
not used by ODA, type is determined from classes of the objects in
the 2nd parameter.
See Also