Cylinder(Double, Point3d, Vector3d) Constructor

Constructor for the Cylinder class. Creates an object with specified radius, origin and axis of symmetry.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public Cylinder(
        double radius,
        Point3d origin,
        Vector3d axisOfSymmetry
)

Parameters

radius  Double
[in] Radius of this cylinder.
origin  Point3d
[in] A point on the axis of symmetry.
axisOfSymmetry  Vector3d
[in] Axis of symmetry (rotation).
See Also

©  Bricsys NV. All rights reserved.