Face(Point3d, Point3d, Point3d,
Point3d, Boolean, Boolean, Boolean, Boolean)
Constructor
|
Constructor for the Face class. Creates a face
with the passed vertices and visibility values for edges.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Face(
Point3d pointer1,
Point3d pointer2,
Point3d pointer3,
Point3d pointer4,
bool value1,
bool value2,
bool value3,
bool value4
)
Public Sub New (
pointer1 As Point3d,
pointer2 As Point3d,
pointer3 As Point3d,
pointer4 As Point3d,
value1 As Boolean,
value2 As Boolean,
value3 As Boolean,
value4 As Boolean
)
public:
Face(
Point3d pointer1,
Point3d pointer2,
Point3d pointer3,
Point3d pointer4,
bool value1,
bool value2,
bool value3,
bool value4
)
new :
pointer1 : Point3d *
pointer2 : Point3d *
pointer3 : Point3d *
pointer4 : Point3d *
value1 : bool *
value2 : bool *
value3 : bool *
value4 : bool -> Face
Parameters
- pointer1 Point3d
- [in] First corner point of a face.
- pointer2 Point3d
- [in] Second corner point of a face.
- pointer3 Point3d
- [in] Third corner point of a face.
- pointer4 Point3d
- [in] Fourth corner point of a face.
- value1 Boolean
- [in] Visibility value for the first edge.
- value2 Boolean
- [in] Visibility value for the second edge.
- value3 Boolean
- [in] Visibility value for the third edge.
- value4 Boolean
- [in] Visibility value for the fourth edge.
See Also