Returns a collection of NURBS knots. A knot
vector defines a sequence of parameter values that determines where
and how the control points affect the curve. The knot vector is a
sequence of parameter values and divides the parametric space into
intervals, usually called knot spans. Values of the knot vector
must be provided in ascending order, for example: (0, 0, 0, 1, 2,
3, 3, 3) can be valid while (0, 0, 2, 0, 3, 1, 3, 3) is not
valid.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public DoubleCollection GetKnots()
Public Function GetKnots As DoubleCollection
public:
DoubleCollection^ GetKnots()
member GetKnots : unit -> DoubleCollection
Return Value
DoubleCollection
See Also