NurbsData Structure

Replaces any existing spline data with the data provided in this object.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesNurbsData

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct NurbsData

The NurbsData type exposes the following members.

Properties
  Name Description
Public property Closed Property that indicates whether the spline is closed. A closed spline is made by creating a smooth spline between the first and last points and joining it with the initial spline.
Public property ControlPointTolerance Property that represents the tolerance value used for operating with control points of NURBS.
Public property Degree Property that represents the NURBS degree. High degree values make the curve more flexible. For example, a degree of 1 is used to define a segment, and a degree of 2 is used to define a NURBS circle, etc.
Public property KnotTolerance Property that represents the tolerance value used for operating with NURBS knots.
Public property Periodic Property that indicates whether the spline is periodic.
Public property Rational Property that indicates whether the spline is rational. If the spline is rational, each control point has a corresponding weight value.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetControlPoints Returns a collection of control points.
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method GetKnots Returns a collection of NURBS knots. A knot vector defines a sequence of parameter values that determines where and how the control points affect the curve. The knot vector is a sequence of parameter values and divides the parametric space into intervals, usually called knot spans. Values of the knot vector must be provided in ascending order, for example: (0, 0, 0, 1, 2, 3, 3, 3) can be valid while (0, 0, 2, 0, 3, 1, 3, 3) is not valid.
Public method GetWeights Returns a collection of NURBS weight values. The closer the weight value is to zero, the closer the curve is to a straight line near the corresponding control point. If the weight increases, the curve pulls toward the corresponding control point. If the weight decreases, the curve pushes from the corresponding control point.
Public method IsEqualTo(NurbsData) Checks whether this object is equal to the specified object.
Public method IsEqualTo(NurbsData, Tolerance) Checks whether this object is equal to the specified object within the specified tolerance.
Top
Operators
  Name Description
Public operatorStatic member Equality(NurbsData, NurbsData) Equality operator for the NurbsData class.
Public operatorStatic member Inequality(NurbsData, NurbsData) Inequality operator for the NurbsData class.
Top
See Also

©  Bricsys NV. All rights reserved.