SurfaceFilletEdges Method
|
Creates rounded fillets along the specified
edges of the surface.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void FilletEdges(
SubentityId[] subentityIds,
DoubleCollection radius,
DoubleCollection startSetback,
DoubleCollection endSetback
)
Public Overridable Sub FilletEdges (
subentityIds As SubentityId(),
radius As DoubleCollection,
startSetback As DoubleCollection,
endSetback As DoubleCollection
)
public:
virtual void FilletEdges(
array<SubentityId>^ subentityIds,
DoubleCollection^ radius,
DoubleCollection^ startSetback,
DoubleCollection^ endSetback
)
abstract FilletEdges :
subentityIds : SubentityId[] *
radius : DoubleCollection *
startSetback : DoubleCollection *
endSetback : DoubleCollection -> unit
override FilletEdges :
subentityIds : SubentityId[] *
radius : DoubleCollection *
startSetback : DoubleCollection *
endSetback : DoubleCollection -> unit
Parameters
- subentityIds SubentityId
- [in] Object IDs of the edges where the fillet is applied.
- radius DoubleCollection
- [in] Array of radius values for the corresponding edges.
- startSetback DoubleCollection
- [in] Array of starting setback values for the corresponding
edges.
- endSetback DoubleCollection
- [in] Array of ending setback values for the corresponding
edges.
Return Value
Array of resulting entities.
Remarks
This method is
implemented only for the Spatial modeler.
See Also