ViewGetNumPixelsInUnitSquare(Point3d,
Boolean) Method
|
Returns the display pixel density at the
specified point for this Viewport object.
Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual Point2d GetNumPixelsInUnitSquare(
Point3d givenWorldpt,
bool includePerspective
)
Public Overridable Function GetNumPixelsInUnitSquare (
givenWorldpt As Point3d,
includePerspective As Boolean
) As Point2d
public:
virtual Point2d GetNumPixelsInUnitSquare(
Point3d givenWorldpt,
bool includePerspective
)
abstract GetNumPixelsInUnitSquare :
givenWorldpt : Point3d *
includePerspective : bool -> Point2d
override GetNumPixelsInUnitSquare :
givenWorldpt : Point3d *
includePerspective : bool -> Point2d
Parameters
- givenWorldpt Point3d
- [in] WCS center of the unit square.
- includePerspective Boolean
- [in] If true, the pixel density calculation process considers
perspective projection.
Return Value
Point2d
Remarks
Pixel density is
measured in pixels per WCS unit. This method can be used to
determine whether the geometry generated for an object is smaller
than the size of a pixel.
See Also