SweepOptionsCheckSweepCurve Method
|
Checks whether the specified swept entity is
valid and returns the planarity of the swept entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public SweepOptionsCheckSweepCurveOut CheckSweepCurve(
Entity sweepEnt,
bool displayErrorMessages
)
Public Function CheckSweepCurve (
sweepEnt As Entity,
displayErrorMessages As Boolean
) As SweepOptionsCheckSweepCurveOut
public:
SweepOptionsCheckSweepCurveOut^ CheckSweepCurve(
Entity^ sweepEnt,
bool displayErrorMessages
)
member CheckSweepCurve :
sweepEnt : Entity *
displayErrorMessages : bool -> SweepOptionsCheckSweepCurveOut
Parameters
- sweepEnt Entity
- [in] Curve, region, or planar surface to be swept.
- displayErrorMessages Boolean
- [in] Indicates whether error messages are displayed.
Return Value
SweepOptionsCheckSweepCurveOut
SweepOptionsCheckSweepCurveOut instance that contains the output
parameters of the method including planarity, point on the swept
entity or point on the line, 'closed' status, approximate arc
length, etc.
See Also