SweepOptionsCheckSweepCurveOut Class

This class stores options for checking sweep curves.
Inheritance Hierarchy
SystemObject
  Teigha.DatabaseServicesSweepOptionsCheckSweepCurveOut

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class SweepOptionsCheckSweepCurveOut

The SweepOptionsCheckSweepCurveOut type exposes the following members.

Constructors
  Name Description
Public method SweepOptionsCheckSweepCurveOut Default constructor for the SweepOptionsCheckSweepCurveOut class.
Top
Properties
  Name Description
Public property ApproximateArcLength Property that represents the approximate arc length.
Public property Closed Property that indicates whether the swept entity is closed.
Public property Planarity Property that represents the planarity of the entity.
Public property Point Property that represents the point on the swept entity if planarity is Planarity.Planar or a point on the line if planarity is Planarity.Linear.
Public property Vector Property that represents the normal vector of the entity if planarity is Planarity.Planar or the line direction if planarity is Planarity.Linear.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.