Cylinder(Double, Point3d, Vector3d, Vector3d, Interval, Double, Double) Constructor

Constructor for the Cylinder class. Creates an object with specified parameters.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public Cylinder(
        double radius,
        Point3d origin,
        Vector3d axisOfSymmetry,
        Vector3d referenceAxis,
        Interval height,
        double startAngle,
        double endAngle
)

Parameters

radius  Double
[in] Radius of this cylinder.
origin  Point3d
[in] A point on the axis of symmetry.
axisOfSymmetry  Vector3d
[in] Axis of symmetry (rotation).
referenceAxis  Vector3d
[in] Defines the 0 angle of the cylinder rotation.
height  Interval
[in] Height interval of this cylinder.
startAngle  Double
 
endAngle  Double
 
See Also

©  Bricsys NV. All rights reserved.