SurfaceProjectOnToSurface
Method
|
Creates entities by projecting the specified
entity along the projection direction to the surface.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Entity[] ProjectOnToSurface(
Entity entityToProject,
Vector3d projectionDirection
)
Public Function ProjectOnToSurface (
entityToProject As Entity,
projectionDirection As Vector3d
) As Entity()
public:
array<Entity^>^ ProjectOnToSurface(
Entity^ entityToProject,
Vector3d projectionDirection
)
member ProjectOnToSurface :
entityToProject : Entity *
projectionDirection : Vector3d -> Entity[]
Parameters
- entityToProject Entity
- [in] Entity to be projected. If the entity to project is
represented by a Point object, the Point object representing the
nearest point on the surface is returned.
- projectionDirection Vector3d
- [in] Vector specifying the direction of the projection.
Return Value
Entity
Array of entities created by the projection.
Remarks
This method is
implemented only for the Spatial modeler.
See Also