CurveGetOffsetCurvesGivenPlaneNormal
Method
|
Creates and returns a set of curves
representing the offset of this curve by the specified distance to
a plane with the specified normal.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual DBObjectCollection GetOffsetCurvesGivenPlaneNormal(
Vector3d normal,
double offsetDist
)
Public Overridable Function GetOffsetCurvesGivenPlaneNormal (
normal As Vector3d,
offsetDist As Double
) As DBObjectCollection
public:
virtual DBObjectCollection^ GetOffsetCurvesGivenPlaneNormal(
Vector3d normal,
double offsetDist
)
abstract GetOffsetCurvesGivenPlaneNormal :
normal : Vector3d *
offsetDist : float -> DBObjectCollection
override GetOffsetCurvesGivenPlaneNormal :
normal : Vector3d *
offsetDist : float -> DBObjectCollection
Parameters
- normal Vector3d
- [in] Normal to a plane.
- offsetDist Double
- [in] Offset distance.
Return Value
DBObjectCollection
See Also