EllipticalArc3dProjectedIntersectWith(LinearEntity3d, Vector3d) Method

Calculates intersection points with the specified plane.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public Point3d[] ProjectedIntersectWith(
        LinearEntity3d line,
        Vector3d projectionDirection
)

Parameters

line  LinearEntity3d
[in] A 3D linear entity with which the intersection is calculated.
projectionDirection  Vector3d
[in] Projection direction.

Return Value

Point3d
If the method fails or there are no intersection points, this method returns nullptr. The returned array consists of four elements. Indexes: * 0 - the first intersection point on this elliptical arc. * 1 - the second intersection point on this elliptical arc (if it exists). * 2 - the first intersection point on the line. * 3 - the second intersection point on the line (if it exists).
See Also

©  Bricsys NV. All rights reserved.