CurveGetProjectedCurve Method
|
Creates a curve by projecting this curve to
the specified plane along the specified direction.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual Curve GetProjectedCurve(
Plane planeToProjectOn,
Vector3d projectionDirection
)
Public Overridable Function GetProjectedCurve (
planeToProjectOn As Plane,
projectionDirection As Vector3d
) As Curve
public:
virtual Curve^ GetProjectedCurve(
Plane^ planeToProjectOn,
Vector3d projectionDirection
)
abstract GetProjectedCurve :
planeToProjectOn : Plane *
projectionDirection : Vector3d -> Curve
override GetProjectedCurve :
planeToProjectOn : Plane *
projectionDirection : Vector3d -> Curve
Parameters
- planeToProjectOn Plane
- [in] Projection plane.
- projectionDirection Vector3d
- [in] Projection direction.
Return Value
Curve
See Also