Performs a deep clone of this object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual DBObject DeepClone(
DBObject ownerPointer,
IdMapping idMap,
bool isPrimary
)
Public Overridable Function DeepClone (
ownerPointer As DBObject,
idMap As IdMapping,
isPrimary As Boolean
) As DBObject
public:
virtual DBObject^ DeepClone(
DBObject^ ownerPointer,
IdMapping^ idMap,
bool isPrimary
)
abstract DeepClone :
ownerPointer : DBObject *
idMap : IdMapping *
isPrimary : bool -> DBObject
override DeepClone :
ownerPointer : DBObject *
idMap : IdMapping *
isPrimary : bool -> DBObject
Parameters
- ownerPointer DBObject
- [in] Object ID of the mapping object.
- idMap IdMapping
- [in] Owner object.
- isPrimary Boolean
- [in] Flag indicating whether this object is primary. If false,
this object is considered owned.
Return Value
DBObject
Returns the newly created clone and adds a record to the specified
ID mapping object.
Remarks
If the cloning
operation fails, an invalid clone is returned. A deep clone is a
clone of this object and everything it owns. This method should not
be called by client code; use the Database.deepCloneObjects()
instead. This method can be overridden in custom classes. The
default implementation of this function appends the cloned object
to the specified owner object.
See Also