IdMapping Class

This class is used in deep clone operations to map, using IdPair objects, object IDs from the original objects to their clones.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesIdMapping

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class IdMapping : RXObject, 
        IEnumerable

The IdMapping type exposes the following members.

Constructors
  Name Description
Public method IdMapping Default constructor for the IdMapping class.
Top
Properties
  Name Description
Public property DeepCloneContext Property that represents the type of deep clone operation that uses this IdMapping object.
Public property DestinationDatabase Property that represents the destination database for the deep clone operation that uses this IdMapping object.
Public property DuplicateRecordCloning Property that represents the type of duplicate record cloning for this IdMapping object.
Public property Item Property that represents the IdPair object defined by its key.
Public property OriginalDatabase Property that represents the source (original) database for the deep clone operation that uses this IdMapping object.
Top
Methods
  Name Description
Public method Add Adds the specified IdPair object to this IdMapping object.
Public method Change Returns the value of the IdPair in this IdMapping object that matches the key in the specified IdPair object.
Public method Contains Checks whether this IdMapping object contains the specified key object ID.
Public method Delete Deletes the IdPair with the specified key from this IdMapping object.
Public method GetEnumerator Returns an enumerator for this object.
Public method Lookup Searches for whether this IdPair stores the specified key. If the specified key is found, the method returns the IdPair object with the rest of copied data, otherwise returns NULL.
Top
Remarks
There is no mechanism to clear all the mappings in an IdMapping instance; a new instance must be created for each deep clone operation.
See Also

©  Bricsys NV. All rights reserved.