NurbCurve3dSetFitData(Point3dCollection,
Vector3d, Vector3d, Tolerance) Method
|
Sets the fit data for this spline.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetFitData(
Point3dCollection fitPoints,
Vector3d startTangent,
Vector3d endTangent,
Tolerance fitTolerance
)
Public Sub SetFitData (
fitPoints As Point3dCollection,
startTangent As Vector3d,
endTangent As Vector3d,
fitTolerance As Tolerance
)
public:
void SetFitData(
Point3dCollection^ fitPoints,
Vector3d startTangent,
Vector3d endTangent,
Tolerance fitTolerance
)
member SetFitData :
fitPoints : Point3dCollection *
startTangent : Vector3d *
endTangent : Vector3d *
fitTolerance : Tolerance -> unit
Parameters
- fitPoints Point3dCollection
- [in] Interpolation points.
- startTangent Vector3d
- [in] Start tangent.
- endTangent Vector3d
- [in] End tangent.
- fitTolerance Tolerance
- [in] Geometric tolerance.
Remarks
Recomputes the
spline from the input fit points and start and end tangents. If
fitTolerance is not 0, the constructed spline may not pass through
the fit points, but the maximum distance from any fit point to the
constructed spline is no greater than fitTolerance.
See Also