GeometryText(Point3d, Vector3d,
Vector3d, Double, Double, Double, String) Method
|
Introduces text into the vectorization
context.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool Text(
Point3d position,
Vector3d normal,
Vector3d direction,
double height,
double width,
double oblique,
string message
)
Public MustOverride Function Text (
position As Point3d,
normal As Vector3d,
direction As Vector3d,
height As Double,
width As Double,
oblique As Double,
message As String
) As Boolean
public:
virtual bool Text(
Point3d position,
Vector3d normal,
Vector3d direction,
double height,
double width,
double oblique,
String^ message
) abstract
abstract Text :
position : Point3d *
normal : Vector3d *
direction : Vector3d *
height : float *
width : float *
oblique : float *
message : string -> bool
Parameters
- position Point3d
- [in] Position of the text string.
- normal Vector3d
- [in] Normal vector of the text.
- direction Vector3d
- [in] Baseline direction of the text.
- height Double
- [in] Height of the text.
- width Double
- [in] Width factor of the text.
- oblique Double
- [in] Oblique (skew) angle.
- message String
- [in] Text string.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
See Also