DatabaseGetObjectId Method
|
Retrieves the object ID corresponding to the
specified handle object in this database.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public ObjectId GetObjectId(
bool createIfNotFound,
Handle objHandle,
int identifier
)
Public Function GetObjectId (
createIfNotFound As Boolean,
objHandle As Handle,
identifier As Integer
) As ObjectId
public:
ObjectId GetObjectId(
bool createIfNotFound,
Handle objHandle,
int identifier
)
member GetObjectId :
createIfNotFound : bool *
objHandle : Handle *
identifier : int -> ObjectId
Parameters
- createIfNotFound Boolean
- [in] Flag that specifies whether to create an object if not
found.
- objHandle Handle
- [in] Database handle of the searched object.
- identifier Int32
- [in] External reference identifier. Currently not
supported.
Return Value
ObjectId
Identifier of a found or created object.
See Also