Handle Structure

This class encapsulates the 64-bit integer handles associated with DBObject instances. Handles are persistent and unique within a database. Handles are not, however, unique between databases.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesHandle

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Handle

The Handle type exposes the following members.

Constructors
  Name Description
Public method Handle Constructor for the Handle class. Initializes a handle with the specified 64-bit integer value.
Top
Properties
  Name Description
Public property IsOne Property that indicates whether this handle is equal to 1.
Public property Value Property that represents the value of the handle.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method ToString Returns an equivalent string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(Handle, Handle) Equality operator for the Handle class.
Public operatorStatic member Inequality(Handle, Handle) Inequality operator for the Handle class.
Top
See Also

©  Bricsys NV. All rights reserved.