Curve3dIsPlanar(Plane) Method
|
Checks whether this curve is planar. If the
curve is a line, this function returns an arbitrary plane that
contains the line. The plane parameter contains meaningful data
only if this function returns a value of true.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsPlanar(
out Plane plane
)
Public Function IsPlanar (
<OutAttribute> ByRef plane As Plane
) As Boolean
public:
bool IsPlanar(
[OutAttribute] Plane^% plane
)
member IsPlanar :
plane : Plane byref -> bool
Parameters
- plane Plane
- [out] Plane on which this curve lies if it is planar.
Return Value
Boolean
true if this curve is planar,
false otherwise.
See Also