EllipticalArc3dIntersectWith(PlanarEntity)
Method
|
Calculates intersection points with the
specified plane.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d[] IntersectWith(
PlanarEntity plane
)
Public Function IntersectWith (
plane As PlanarEntity
) As Point3d()
public:
array<Point3d>^ IntersectWith(
PlanarEntity^ plane
)
member IntersectWith :
plane : PlanarEntity -> Point3d[]
Parameters
- plane PlanarEntity
- [in] Plane with which to calculate intersections.
Return Value
Point3d
If the method fails or there are no intersection points, this
method returns nullptr. The returned array consists of two
elements. The first element corresponds to the first intersection
point (if it exists), the second element corresponds to the second
intersection point (if it exists).
See Also