CircularArc3d(Point3d, Vector3d,
Vector3d, Double, Double, Double) Constructor
|
Constructor for the CircularArc3d class.
Creates a circle with the specified center, normal and
radius.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public CircularArc3d(
Point3d center,
Vector3d normal,
Vector3d referenceVector,
double radius,
double startAngle,
double endAngle
)
Public Sub New (
center As Point3d,
normal As Vector3d,
referenceVector As Vector3d,
radius As Double,
startAngle As Double,
endAngle As Double
)
public:
CircularArc3d(
Point3d center,
Vector3d normal,
Vector3d referenceVector,
double radius,
double startAngle,
double endAngle
)
new :
center : Point3d *
normal : Vector3d *
referenceVector : Vector3d *
radius : float *
startAngle : float *
endAngle : float -> CircularArc3d
Parameters
- center Point3d
- [in] Center of a circular arc.
- normal Vector3d
- [in] Normal vector of a 3D circular arc.
- referenceVector Vector3d
- [in] Vector that indicates the direction of the zero rotation
angle of this circular arc.
- radius Double
- [in] Radius of this circular arc.
- startAngle Double
- [in] Start angle of a circular arc.
- endAngle Double
- [in] End angle of a circular arc (must be greater than
startAngle).
See Also