NurbsDataIsEqualTo(NurbsData,
Tolerance) Method
|
Checks whether this object is equal to the
specified object within the specified tolerance.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsEqualTo(
NurbsData other,
Tolerance tolerance
)
Public Function IsEqualTo (
other As NurbsData,
tolerance As Tolerance
) As Boolean
public:
bool IsEqualTo(
NurbsData other,
Tolerance tolerance
)
member IsEqualTo :
other : NurbsData *
tolerance : Tolerance -> bool
Parameters
- other NurbsData
- [in] Other object to check for equality.
- tolerance Tolerance
- [in] Tolerance.
Return Value
Boolean
true if all the following conditions are met within the specified
tolerance: * Control points are equal. * Knot vectors are equal. *
Degrees are equal. * Both splines are either rational or
irrational. * Both splines are either closed or not. * Both splines
are either periodic or not.
See Also