EllipticalCylinderSet(Double, Double,
Point3d, Vector3d, Vector3d, Interval, Double,
Double) Method
|
Sets the specified radii, origin, axis of
symmetry, major axis, height interval, and start and end angles for
this elliptical cylinder.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void Set(
double minorRadius,
double majorRadius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d majorAxis,
Interval height,
double startAngle,
double endAngle
)
Public Sub Set (
minorRadius As Double,
majorRadius As Double,
origin As Point3d,
axisOfSymmetry As Vector3d,
majorAxis As Vector3d,
height As Interval,
startAngle As Double,
endAngle As Double
)
public:
void Set(
double minorRadius,
double majorRadius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d majorAxis,
Interval^ height,
double startAngle,
double endAngle
)
member Set :
minorRadius : float *
majorRadius : float *
origin : Point3d *
axisOfSymmetry : Vector3d *
majorAxis : Vector3d *
height : Interval *
startAngle : float *
endAngle : float -> unit
Parameters
- minorRadius Double
- [in] Minor radius of this elliptical cylinder.
- majorRadius Double
- [in] Major radius of this elliptical cylinder.
- origin Point3d
- [in] Origin point of this elliptical cylinder.
- axisOfSymmetry Vector3d
- [in] Axis of symmetry (rotation).
- majorAxis Vector3d
- [in] The major axis of this elliptical cylinder.
- height Interval
- [in] Height interval of this elliptical cylinder.
- startAngle Double
- [in] Start angle of this elliptical cylinder (angle offset from
which elliptical cylinder segments are drawn).
- endAngle Double
- [in] End angle of this elliptical cylinder (angle offset to
which elliptical cylinder segments are drawn).
See Also