EllipticalCylinder Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometrySurface
          Teigha.GeometryEllipticalCylinder

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class EllipticalCylinder : Surface

The EllipticalCylinder type exposes the following members.

Constructors
  Name Description
Public method EllipticalCylinder Default constructor for the EllipticalCylinder class. Creates a default corresponding C++ object with a reference axis of (1,0,0), a baseOrigin of (0,0,0), an axisOfSymmetry of (0,1,0), and base radii of 2.0.
Public method EllipticalCylinder(Double, Double, Point3d, Vector3d) Constructor for the EllipticalCylinder class. Creates an object with specified radii, base origin and axis of symmetry.
Public method EllipticalCylinder(Double, Double, Point3d, Vector3d, Vector3d, Interval, Double, Double) Constructor for the EllipticalCylinder class. Creates an object with specified radii, base origin, and axis of symmetry.
Top
Properties
  Name Description
Public property Height  
Public property IsOuterNormal  
Public property MajorAxis  
Public property MajorRadius  
Public property MinorAxis  
Public property MinorRadius  
Public property Origin  
Public property RadiusRatio  
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetAngles Gets the start and end angles of this elliptical cylinder.
Public method GetHeightAt Returns the height of this elliptical cylinder corresponding to the specified position on the U-axis (parameter).
Public method IntersectWith(LinearEntity3d) Calculates intersection points with the specified linear entity.
Public method IntersectWith(LinearEntity3d, Tolerance) Calculates intersection points with the specified linear entity according to a geometric tolerance.
Public method IsClosed Checks whether the base of this elliptical cylinder is a full ellipse.
Public method IsClosed(Tolerance) Checks whether the base of this elliptical cylinder is a full ellipse within the specified tolerance.
Public method Set(Double, Double, Point3d, Vector3d) Sets the specified radii, origin, and axis of symmetry for this elliptical cylinder.
Public method Set(Double, Double, Point3d, Vector3d, Vector3d, Interval, Double, Double) Sets the specified radii, origin, axis of symmetry, major axis, height interval, and start and end angles for this elliptical cylinder.
Public method SetAngles Sets the specified start and end angles for this elliptical cylinder.
Top
See Also

©  Bricsys NV. All rights reserved.