MaterialMap(Source, String, MaterialTexture, Double, Mapper) Constructor

Constructor for the MaterialMap class. Creates a map from the specified source that includes a file path (if source is File), with a material texture, blend factor, and mapper.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public MaterialMap(
        Source source,
        string fileName,
        MaterialTexture pTexture,
        double blendFactor,
        Mapper mapper
)

Parameters

source  Source
[in] Material map source.
fileName  String
[in] Full path to the file for this material map.
pTexture  MaterialTexture
[in] Material texture.
blendFactor  Double
[in] Blend factor for a texture.
mapper  Mapper
[in] Material mapper.
Remarks
The blend parameter specifies how much texture is blended with a material. The texture becomes dissolved (invisible) by the underlaying material color when the blend factor is 0.0. Values between 0.0 and 1.0 mean that the texture is partly transparent. The texture becomes fully opaque when the blend factor is 0.0. The texture colors are blended with the underlaying material color when the blend factor is above 1.0.
See Also

©  Bricsys NV. All rights reserved.