Mapper Class

This class implements mappers. Mappers determine how a material map is mapped to object surfaces.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceMapper

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class Mapper : RXObject

The Mapper type exposes the following members.

Constructors
  Name Description
Public method Mapper Default constructor for the Mapper class. Constructs a mapper with planar projection, repeating the map along its axes (u and v tiling) and with no automatic transformation of a material map. By default an identity matrix is used to transform a map.
Public method Mapper(Projection, Tiling, Tiling, AutoTransform, Matrix3d) Constructor for the Mapper class. Constructs a mapper with specified projection type, tiling for U and V, automatic transformation type and transformation matrix.
Top
Properties
  Name Description
Public property AutoTransform  
Public property Projection  
Public property Transform  
Public property UTiling  
Public property VTiling  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides DisposableWrapperEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides DisposableWrapperGetHashCode)
Top
See Also

©  Bricsys NV. All rights reserved.