MemberComponentCollection Class

This class represents a collection of structural member components.
Inheritance Hierarchy
SystemObject
  Teigha.Aec.Structural.DatabaseServicesMemberComponentCollection

Namespace: Teigha.Aec.Structural.DatabaseServices
Assembly: TA_MgdStructure (in TA_MgdStructure.dll) Version: 0.0.0.0
Syntax
public sealed class MemberComponentCollection : IList

The MemberComponentCollection type exposes the following members.

Constructors
  Name Description
Public method MemberComponentCollection Constructor for the MemberComponentCollection class.
Top
Properties
  Name Description
Public property Count Represents the number of elements that this collection currently stores.
Public property Item Property that represents a structural member component at the specified index.
Top
Methods
  Name Description
Public method Add Adds the specified structural member component as the next object in the collection.
Public method Clear Erases all items from the collection.
Public method Contains Checks whether this collection contains the specified structural member component.
Public method CopyTo Copies this collection to the specified array at the specified index.
Public method GetEnumerator Returns the enumerator for this collection of structural member components.
Public method IndexOf Returns the index of the structural member component in the collection that matches the specified structural member component.
Public method Insert Inserts the specified structural member component to the collection at the provided index.
Public method Remove Removes a structural member component that matches the specified structural member component from the collection.
Public method RemoveAt Removes a structural member component from the collection at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.